        <!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns#">
    	<head>

		        <meta charset="UTF-8">
        <meta name="viewport" content="width=device-width, initial-scale=1">
        <link rel="profile" href="http://gmpg.org/xfn/11">
        <link rel="pingback" href="http://xpresstimes.co.ug/xmlrpc.php">
    
<meta property="og:image" content="http://xpresstimes.co.ug/wp-content/uploads/2020/01/p-300x206.jpg"/>
<!-- This site is optimized with the Yoast SEO plugin v3.0.7 - https://yoast.com/wordpress/plugins/seo/ -->
<title>Ham Group Masterminding Mass Development in Real Estates and Agro processng in Uganda - Xpress Times Uganda</title>
<link rel="canonical" href="http://xpresstimes.co.ug/2020/01/15/ham-group-and-the-masterminding-mass-development-in-uganda/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Ham Group Masterminding Mass Development in Real Estates and Agro processng in Uganda - Xpress Times Uganda" />
<meta property="og:description" content="Aerial artistic view of the Ham Agro processing industries being constructed by Roko By Xpress Times The real estate and property development sector is fast taking shape at an imaginable speed in the country. Of course with the recent wave many cities and metropolitan centers have changed faces with the modern facilities being elected day and night. Truth be told, many have over the years tried, others failed somewhere, while others have had their real estate and property developments stunted due to reasons well known to them. Such has left&hellip;" />
<meta property="og:url" content="http://xpresstimes.co.ug/2020/01/15/ham-group-and-the-masterminding-mass-development-in-uganda/" />
<meta property="og:site_name" content="Xpress Times Uganda" />
<meta property="article:section" content="BUSINESS" />
<meta property="og:image" content="http://xpresstimes.co.ug/wp-content/uploads/2020/01/p.jpg" />
<meta name="twitter:card" content="summary"/>
<meta name="twitter:description" content="Aerial artistic view of the Ham Agro processing industries being constructed by Roko By Xpress Times The real estate and property development sector is fast taking shape at an imaginable speed in the country. Of course with the recent wave many cities and metropolitan centers have changed faces with the modern facilities being elected day and night. Truth be told, many have over the years tried, others failed somewhere, while others have had their real estate and property developments stunted due to reasons well known to them. Such has left&hellip;"/>
<meta name="twitter:title" content="Ham Group Masterminding Mass Development in Real Estates and Agro processng in Uganda - Xpress Times Uganda"/>
<meta name="twitter:image" content="http://xpresstimes.co.ug/wp-content/uploads/2020/01/p.jpg"/>
<!-- / Yoast SEO plugin. -->

<link rel="alternate" type="application/rss+xml" title="Xpress Times Uganda &raquo; Feed" href="http://xpresstimes.co.ug/feed/" />
<link rel="alternate" type="application/rss+xml" title="Xpress Times Uganda &raquo; Comments Feed" href="http://xpresstimes.co.ug/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Xpress Times Uganda &raquo; Ham Group Masterminding  Mass Development in Real Estates and Agro processng in Uganda Comments Feed" href="http://xpresstimes.co.ug/2020/01/15/ham-group-and-the-masterminding-mass-development-in-uganda/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"http:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/xpresstimes.co.ug\/wp-includes\/js\/wp-emoji-release.min.js?ver=0071cdabcf9620ab186a7087346cafc9"}};
			!function(a,b,c){function d(a){var c=b.createElement("canvas"),d=c.getContext&&c.getContext("2d");return d&&d.fillText?(d.textBaseline="top",d.font="600 32px Arial","flag"===a?(d.fillText(String.fromCharCode(55356,56812,55356,56807),0,0),c.toDataURL().length>3e3):(d.fillText(String.fromCharCode(55357,56835),0,0),0!==d.getImageData(16,16,1,1).data[0])):!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g;c.supports={simple:d("simple"),flag:d("flag")},c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.simple&&c.supports.flag||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='A5-framework-css'  href='http://xpresstimes.co.ug/a5-framework-frontend.css?ver=0071cdabcf9620ab186a7087346cafc9beta20150909CLP' type='text/css' media='all' />
<link rel='stylesheet' id='utbap_lib_css-css'  href='http://xpresstimes.co.ug/wp-content/plugins/add-youtube-feed/includes/../css/youmax-pro.min.css?ver=0071cdabcf9620ab186a7087346cafc9' type='text/css' media='all' />
<link rel='stylesheet' id='facebookall-button-style-css'  href='http://xpresstimes.co.ug/wp-content/plugins/facebookall/assets/css/fball_fbbutton.css?ver=0071cdabcf9620ab186a7087346cafc9' type='text/css' media='all' />
<link rel='stylesheet' id='hupso_css-css'  href='http://xpresstimes.co.ug/wp-content/plugins/hupso-share-buttons-for-twitter-facebook-google/style.css?ver=0071cdabcf9620ab186a7087346cafc9' type='text/css' media='all' />
<link rel='stylesheet' id='post_hit_counter-frontend-css'  href='http://xpresstimes.co.ug/wp-content/plugins/post-hit-counter/assets/css/frontend.css?ver=0071cdabcf9620ab186a7087346cafc9' type='text/css' media='all' />
<link rel='stylesheet' id='wp125style-css'  href='http://xpresstimes.co.ug/wp-content/plugins/wp125/wp125.css?ver=0071cdabcf9620ab186a7087346cafc9' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-bxslider-css'  href='http://xpresstimes.co.ug/wp-content/plugins/bb-plugin/css/jquery.bxslider.css?ver=0071cdabcf9620ab186a7087346cafc9' type='text/css' media='all' />
<link rel='stylesheet' id='supermag-googleapis-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A600%2C400%7CRoboto%3A300italic%2C400%2C500%2C700&#038;ver=0071cdabcf9620ab186a7087346cafc9' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='http://xpresstimes.co.ug/wp-content/plugins/bb-plugin/css/font-awesome.min.css?ver=0071cdabcf9620ab186a7087346cafc9' type='text/css' media='all' />
<link rel='stylesheet' id='supermag-style-css'  href='http://xpresstimes.co.ug/wp-content/themes/supermag/style.css?ver=0071cdabcf9620ab186a7087346cafc9' type='text/css' media='all' />
<style id='supermag-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='post_hit_counter-widget-css'  href='http://xpresstimes.co.ug/wp-content/plugins/post-hit-counter/assets/css/widget.css?ver=0071cdabcf9620ab186a7087346cafc9' type='text/css' media='all' />
<script type='text/javascript' src='http://xpresstimes.co.ug/wp-includes/js/jquery/jquery.js?ver=0071cdabcf9620ab186a7087346cafc9'></script>
<script type='text/javascript' src='http://xpresstimes.co.ug/wp-includes/js/jquery/jquery-migrate.min.js?ver=0071cdabcf9620ab186a7087346cafc9'></script>
<script type='text/javascript' src='http://xpresstimes.co.ug/wp-content/plugins/add-youtube-feed/includes/../js/youmax-pro.min.js?ver=0071cdabcf9620ab186a7087346cafc9'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://xpresstimes.co.ug/wp-content/themes/supermag/assets/library/html5shiv/html5shiv.min.js?ver=0071cdabcf9620ab186a7087346cafc9'></script>
<![endif]-->
<!--[if lt IE 9]>
<script type='text/javascript' src='http://xpresstimes.co.ug/wp-content/themes/supermag/assets/library/respond/respond.min.js?ver=0071cdabcf9620ab186a7087346cafc9'></script>
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://xpresstimes.co.ug/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://xpresstimes.co.ug/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='http://xpresstimes.co.ug/?p=9552' />
<script type='text/javascript' src='http://xpresstimes.co.ug/wp-content/plugins/facebookall/assets/js/fball_connect.js?ver=0071cdabcf9620ab186a7087346cafc9'></script>
<style>/* CSS added by WP Meta and Date Remover*//* Remove meta from post */
.entry-meta {
display:none !important;
}

/* Remove meta from home page */
.home .entry-meta { 
display: none; 
}
/* WPTheme 2015 Metadata Removal */
.entry-footer {
display:none !important;
}

/* WPTheme 2015 Metadata Removal */
.home .entry-footer { 
display: none; 
}</style><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #fecb0b; }
</style>
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//xpresstimes.co.ug/?wordfence_logHuman=1&hid=A3676B6A6CCA30DE0A0F6F83108EFCE7');
</script><link rel="icon" href="http://xpresstimes.co.ug/wp-content/uploads/2017/10/cropped-xp-logo.fw_1-32x32.png" sizes="32x32" />
<link rel="icon" href="http://xpresstimes.co.ug/wp-content/uploads/2017/10/cropped-xp-logo.fw_1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://xpresstimes.co.ug/wp-content/uploads/2017/10/cropped-xp-logo.fw_1-180x180.png">
<meta name="msapplication-TileImage" content="http://xpresstimes.co.ug/wp-content/uploads/2017/10/cropped-xp-logo.fw_1-270x270.png">
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.4";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-71306402-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-71306402-1');
</script>


	</head>

<body class="single single-post postid-9552 single-format-standard custom-background boxed-layout supermag-enable-box-shadow single-large-image left-logo-right-ads right-sidebar at-sticky-sidebar group-blog">


        <div id="page" class="hfeed site">
        <a class="skip-link screen-reader-text" href="#content" title="link">Skip to content</a>
            <header id="masthead" class="site-header" role="banner">
            <div class="top-header-section clearfix">
                <div class="wrapper">
                     <div class="header-latest-posts float-left bn-title">Wednesday, January 15, 2020</div>                            <div class="header-latest-posts bn-wrapper float-left">
                                <div class="bn-title">
                                    Recent posts                                </div>
                                <ul class="duper-bn">
                                                                            <li class="bn-content">
                                            <a href="http://xpresstimes.co.ug/2020/01/15/2319-sites-selected-for-cctvs-installation-cross-country/" title="2,319 sites selected for CCTVs  installation cross country .">
                                                2,319 sites selected for CCTVs  installation cross country .                                            </a>
                                        </li>
                                                                            <li class="bn-content">
                                            <a href="http://xpresstimes.co.ug/2020/01/15/ham-group-and-the-masterminding-mass-development-in-uganda/" title="Ham Group Masterminding  Mass Development in Real Estates and Agro processng in Uganda">
                                                Ham Group Masterminding  Mass Development in Real Estates and Agro processng in Uganda                                            </a>
                                        </li>
                                                                            <li class="bn-content">
                                            <a href="http://xpresstimes.co.ug/2020/01/13/katosi-water-works-takes-shape/" title="Katosi Water Works Takes Shape">
                                                Katosi Water Works Takes Shape                                            </a>
                                        </li>
                                                                            <li class="bn-content">
                                            <a href="http://xpresstimes.co.ug/2020/01/13/lot-show-case-social-media-party-tycoon-sudhir-ucc-making-1st-ever-fest-slated-possible/" title="A Lot to show case at the Social Media Party with Tycoon Sudhir and UCC making the 1st ever Fest Slated Possible">
                                                A Lot to show case at the Social Media Party with Tycoon Sudhir and UCC making the 1st ever Fest Slated Possible                                            </a>
                                        </li>
                                                                            <li class="bn-content">
                                            <a href="http://xpresstimes.co.ug/2020/01/13/a-case-of-nepotism-as-bou-human-resource-boss-gives-son-job-at-bank-even-without-qualifications/" title="A Case of Nepotism as BoU human resource boss Gives son Job at Bank even without qualifications">
                                                A Case of Nepotism as BoU human resource boss Gives son Job at Bank even without qualifications                                            </a>
                                        </li>
                                                                    </ul>
                            </div> <!-- .header-latest-posts -->
                                            <div class="right-header float-right">
                                <div class="socials">
                            <a href="https://web.facebook.com/xpresstimes/" class="facebook" data-title="Facebook" target="_blank">
                    <span class="font-icon-social-facebook"><i class="fa fa-facebook"></i></span>
                </a>
                            <a href="https://twitter.com/XpressTimes_Ug" class="twitter" data-title="Twitter" target="_blank">
                    <span class="font-icon-social-twitter"><i class="fa fa-twitter"></i></span>
                </a>
                            <a href="https://www.youtube.com/channel/UCKJ_IWcKLcEEc2MVVQh_zzw" class="youtube" data-title="Youtube" target="_blank">
                    <span class="font-icon-social-youtube"><i class="fa fa-youtube"></i></span>
                </a>
                            <a href="http://www.instagram.com" class="instagram" data-title="Instagram" target="_blank">
                    <span class="font-icon-social-instagram"><i class="fa fa-instagram"></i></span>
                </a>
                            <a href="https://plus.google.com/100489350253040843277" class="google-plus" data-title="Google Plus" target="_blank">
                    <span class="font-icon-social-google-plus"><i class="fa fa-google-plus"></i></span>
                </a>
                        </div>
                            </div>
                </div>
            </div><!-- .top-header-section -->
            <div class="header-wrapper clearfix">
                <div class="header-container">
	                                    <div class="wrapper">
                        <div class="site-branding clearfix">
                                                            <div class="site-logo float-left">
                                                                                    <a href="http://xpresstimes.co.ug/" rel="home">
                                                    <img src="http://xpresstimes.co.ug/wp-content/uploads/2017/10/xp-logo.fw_1.png" alt="Xpress Times Uganda">
                                                </a>
                                                                                </div><!--site-logo-->
                                                            <div class="header-ads float-right">
                                                                            <a href="https://www.fortebet.ug/?utm_source=xpresstimes_co_ug&#038;utm_medium=banner_leaderboardHP&#038;utm_campaign=test_free" target="_blank">
                                            <img src="http://xpresstimes.co.ug/wp-content/uploads/2019/02/banner_728x90_01.gif">
                                        </a>
                                                                        </div>
                                                        <div class="clearfix"></div>
                        </div>
                    </div>
	                                    <nav id="site-navigation" class="main-navigation  clearfix" role="navigation">
                        <div class="header-main-menu wrapper clearfix">
                            <div class="acmethemes-nav"><ul id="menu-menu5" class="menu"><li id="menu-item-4809" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-4809"><a href="http://xpresstimes.co.ug">HOME</a></li>
<li id="menu-item-4798" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4798"><a href="http://xpresstimes.co.ug/category/breaking-news/">BREAKING NEWS</a></li>
<li id="menu-item-4799" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4799"><a href="http://xpresstimes.co.ug/category/business/">BUSINESS</a></li>
<li id="menu-item-4800" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4800"><a href="http://xpresstimes.co.ug/category/education/">EDUCATION</a></li>
<li id="menu-item-4801" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4801"><a href="http://xpresstimes.co.ug/category/entertainment/">ENTERTAINMENT</a></li>
<li id="menu-item-4802" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4802"><a href="http://xpresstimes.co.ug/category/gossip/">GOSSIP</a></li>
<li id="menu-item-4803" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4803"><a href="http://xpresstimes.co.ug/category/life-style/">LIFE STYLE</a></li>
<li id="menu-item-4804" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4804"><a href="http://xpresstimes.co.ug/category/politics/">POLITICS</a></li>
<li id="menu-item-4805" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4805"><a href="http://xpresstimes.co.ug/category/religion/">RELIGION</a></li>
<li id="menu-item-4806" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4806"><a href="http://xpresstimes.co.ug/category/sports/">SPORTS</a></li>
</ul></div><div class="random-post">                                        <a title="Uganda Cranes eliminated from CHAN after draw with Zimbabwe" href="http://xpresstimes.co.ug/2016/01/28/756/">
                                            <i class="fa fa-random icon-menu"></i>
                                        </a>
                                        </div><i class="fa fa-search icon-menu search-icon-menu"></i><div class='menu-search-toggle'><div class='menu-search-inner'><div class="search-block">
    <form action="http://xpresstimes.co.ug" class="searchform" id="searchform" method="get" role="search">
        <div>
            <label for="menu-search" class="screen-reader-text"></label>
                        <input type="text"  placeholder="Search"  id="menu-search" name="s" value="">
            <button class="fa fa-search" type="submit" id="searchsubmit"></button>
        </div>
    </form>
</div>
</div></div>                        </div>
                        <div class="responsive-slick-menu clearfix"></div>
                    </nav>
                    <!-- #site-navigation -->
	                                </div>
                <!-- .header-container -->
            </div>
            <!-- header-wrapper-->
        </header>
        <!-- #masthead -->
            <div class="wrapper content-wrapper clearfix">
            <div id="content" class="site-content">
    	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
			
<article id="post-9552" class="post-9552 post type-post status-publish format-standard has-post-thumbnail hentry category-business">
	<header class="entry-header">
		<h1 class="entry-title">Ham Group Masterminding  Mass Development in Real Estates and Agro processng in Uganda</h1>
		<div class="entry-meta">
			<span class="posted-on"><a href="http://xpresstimes.co.ug/2020/01/15/ham-group-and-the-masterminding-mass-development-in-uganda/" rel="bookmark"><i class="fa fa-calendar"></i><time class="entry-date published" datetime=""></time><time class="updated" datetime=""></time></a></span><span class="byline"> <span class="author vcard"><a class="url fn n" href="http://xpresstimes.co.ug/author/admin/"><i class="fa fa-user"></i></a></span></span>		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

	<!--post thumbnal options-->
			<div class="single-feat clearfix">
			<figure class="single-thumb single-thumb-full">
				<img width="960" height="659" src="http://xpresstimes.co.ug/wp-content/uploads/2020/01/p.jpg" class="attachment-full wp-post-image" alt="p" />			</figure>
		</div><!-- .single-feat-->
		<div class="entry-content">
		<htm>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- new1 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-7511299510994171"
     data-ad-slot="7156082642"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</html><p><em><strong>Aerial artistic view of the Ham Agro processing industries being constructed by Roko</strong></em></p>
<p>By Xpress Times<br />
The real estate and property development sector is fast taking shape at an imaginable speed in the country. Of course with the recent wave many cities and metropolitan centers have changed faces with the modern facilities being elected day and night.</p>
<p>Truth be told, many have over the years tried, others failed somewhere, while others have had their real estate and property developments stunted due to reasons well known to them.</p>
<p>Such has left many off track while others bowed out of the business paving way for very few wealth men and women into the business that demands a lot of finances at your disposal.</p>
<p>Here at Xpress times we will give you all about into the real estate and property development business plus the many different projects undertaken by the enterprising powerhouses.</p>
<p>We will zero in one determined and focused enterprising houses that have centered all their energies and all they have in real estate and property development as they have changed faces of Kampala and its suburbs.</p>
<p>Ham Group (Hamis Kiggundu)<br />
Through diverse projects, Ham Enterprises Uganda Limited, now Ham Group of Companies International headed by Hamis Kiggundu (Popularly known as HAM), believes that the best way to live beautifully is to make the world a better place than they found it.<br />
Whatever way you plan; plan to build, change, help create jobs, add value to both peoples lives and National produce and be ready to risk. The Group operations are driven by their slogan &#8220;Try not to become a man of success&#8230; Rather become a man of value.&#8221;<br />
To begin with, are the one stop shopping centers that have been put up by Ham Group. Talk of both Ham Towers and Ham Shopping Mall at Makerere, housing financial institutes, a collection of shopping stores, institutions, health and fitness centers, accommodation suites, entertainment and relaxing centers among many others. These are properties that have not only made life easy for shopping and doing business but have greatly changed the beauty and outlook of not only Makerere hill but Kampala City at Large.</p>
<p>In a joint partnership with the government, Ham has embarked on building a multi-billion modern football stadium and the adjacent Ham Shopping Grounds at Nakivubo, a place which used to harbor Kampala thugs, notorious criminals and very congested,disorganized vendors: now houses thousands of very organised traders in the shops that not only simplify shopping for the public, but generates much revenues for both the central and local government through tax and trade license payment.<em><strong> </strong></em></p>
<p><a href="http://xpresstimes.co.ug/wp-content/uploads/2020/01/N1.jpg"><img class="wp-image-9575 aligncenter" src="http://xpresstimes.co.ug/wp-content/uploads/2020/01/N1-300x169.jpg" alt="N1" width="394" height="194" /></a></p>
<p><em><strong>    Artistic impression  multi-billion modern football stadium and adjacent to Ham Shopping Grounds at Nakivubo      </strong></em><br />
Ham’s massive success has been arrived at through the commitment and drive of the entire team at Ham Group in ensuring that they scale higher standards by the years.</p>
<p><a href="http://xpresstimes.co.ug/wp-content/uploads/2020/01/a4.jpg"><img class="wp-image-9573 aligncenter" src="http://xpresstimes.co.ug/wp-content/uploads/2020/01/a4-300x169.jpg" alt="a4" width="406" height="228" /></a></p>
<p>Ham’s economic growth is no doubt establishing footholds in Uganda in recent years and tremendous business opportunities for local &amp; foreign players; the demand for commercial space in the country is rapidly on the rise. This demand has been rarely met in Kampala. Ham Enterprises seeks to exploit this unmet demand.<br />
The Group has diversified into the education, manufacturing, merchandise and Agro-Processing among many others<a href="http://xpresstimes.co.ug/wp-content/uploads/2020/01/t3.jpg"><img class="wp-image-9566 aligncenter" src="http://xpresstimes.co.ug/wp-content/uploads/2020/01/t3-300x225.jpg" alt="t3" width="384" height="284" /></a> <a href="http://xpresstimes.co.ug/wp-content/uploads/2020/01/t4.jpg"><img class="wp-image-9567 aligncenter" src="http://xpresstimes.co.ug/wp-content/uploads/2020/01/t4-300x197.jpg" alt="t4" width="390" height="268" /></a> <a href="http://xpresstimes.co.ug/wp-content/uploads/2020/01/t5.jpg"><img class="wp-image-9568 aligncenter" src="http://xpresstimes.co.ug/wp-content/uploads/2020/01/t5-300x225.jpg" alt="t5" width="397" height="254" /></a></p>
<p><em><strong>Current progress of Ham villas being set up by Hamis Kiggundu</strong></em><br />
The Ham Palm Villas, Akright City and Ham Agro Processing Industries are two of the projects that will define life and its beauty.<br />
Ham Palm Villas located at Akright City next to the Golf course, where Hamis Kiggundu is setting up 500 homes, Villas and Apartments with State of the Art Multi-Sports facilities, club house, supermarket, Hospital and Swimming pool among very many others. This will probably be the best residential community in Uganda.</p>
<p><a href="http://xpresstimes.co.ug/wp-content/uploads/2020/01/h3.jpg"><img class="wp-image-9556 aligncenter" src="http://xpresstimes.co.ug/wp-content/uploads/2020/01/h3-300x212.jpg" alt="h3" width="439" height="237" /></a><br />
&#8220;<em><strong>Ham Palm Villas will not just be homes but a lifestyle</strong></em>. “We don&#8217;t deserve to simply survive but equally live just like others do in developed countries. We should struggle not to leave our motherland in search of a better life out there but simply struggle to create what we desire here in Uganda with God&#8217;s will as a constant Factor. Uganda will develop, Insha Allah.” Ham notes.<br />
With such developments, Uganda will indeed be like the developed countries that we greatly desire, thus<br />
we at express times are indeed grateful and very thankful to God, for such individuals like Hamis with a very patriotic heart, struggling to create our desires right here in Uganda.We call upon those with his kind of ability to emulate him and together lets develop our motherland.</p>
<p><a href="http://xpresstimes.co.ug/wp-content/uploads/2020/01/a21.jpg"><img class="alignnone wp-image-9569" src="http://xpresstimes.co.ug/wp-content/uploads/2020/01/a21-300x142.jpg" alt="a2" width="412" height="223" /></a></p>
<p><em><strong>Hamis kiggundu with with Roko Construction team after  signing the Aggro processing  construction agreement </strong></em><br />
With agro processing, Ham Enterprises just concluded a contract with Roko Construction to start Construction of Phase one of an Integrated Agro processing plant mainly to add value to local agro produce which will increase on their demand and market domestically, regionally and internationally.</p>
<p>Ham Agro processing industries aims at promoting import substitution thus less money leaving the country with a limited dependency syndrome as a nation, increased regional and international exports thus increased national incomes, increased farmers’ incomes which will not only improve their lives but equally empower them with the ability to pay taxes thus widening the national tax base.</p>
<p>In his book Success and Failure Based on Reason and Reality, Ham stated that: “When we travel abroad, as we go through the airport terminals, we are never judged by who we are or how much money we have on our bank accounts but judged by the passports we hold and our country of origin.</p>
<p><a href="http://xpresstimes.co.ug/wp-content/uploads/2018/07/ham-3.jpg"><img class="alignnone wp-image-6547" src="http://xpresstimes.co.ug/wp-content/uploads/2018/07/ham-3-300x169.jpg" alt="ham 3" width="444" height="223" /></a></p>
<p>Being successful in a poor society is partial success, that’s why I am currently investing in agro processing and value addition to not only grow my empire but also make a difference in my society.” Which brings us to his recently started project;<br />
Ham Agro Processing Industries Ltd, where he contracted Roko Constructions to Set up Agro-Processing, Packaging, storage/warehouses and the administration block and the infrastructure involved in the process.</p>
<p><em><strong>According to Ham</strong></em>, this project is mainly aimed at adding value to our agro produce which will increase on their demand and market domestically, regionally and internationally and hence import Substitution since as a nation we currently import almost everything despite the fact that we are an agro-based country: with this project therefore, more will be produced for our domestic market and the surplus exported, thereby limiting the dependency syndrome and increasing the national income from the exports.</p>
<p>The project will also improve people lives right from the village levels as many jobs will be created to sustain people&#8217;s livelihood as well as market for the village farmers produce that will be the main raw material.(Source: Hamis Kiggundu YouTube Videos).</p>
<p>Hamis is a true living legend at such a tender age who justifies and lives by his word, given the fact that he talked about this way back in 2017 and also in his book,many including us here have been taking it as just mere say, but everything talked about and promised to the nation is now under Manifestation.<br />
For Ham, apparently his heart is for Uganda and the Ugandans. He wants Uganda develop to competitive levels with her populace empowered in many ways socially, economically and perhaps politically through his Ham Group of Companies.<br />
Surely Ham Group has created thousands and thousands of jobs to both local and international populations and more jobs are being created by day. He currently employs 1500 people globally.</p>
<div style="padding-bottom:20px; padding-top:10px;" class="hupso-share-buttons"><!-- Hupso Share Buttons - http://www.hupso.com/share/ --><a class="hupso_counters" href="http://www.hupso.com/share/"><img src="http://static.hupso.com/share/buttons/share-small.png" style="border:0px; padding-top:2px; float:left;" alt="Share Button"/></a><script type="text/javascript">var hupso_services_c=new Array("twitter","facebook_like","facebook_send","google","pinterest","email","print","linkedin");var hupso_twitter_via = "XpressTimes_Ug";var hupso_counters_lang = "en_US";var hupso_image_folder_url = "";var hupso_twitter_via="XpressTimes_Ug";var hupso_url_c="";var hupso_title_c="Ham Group Masterminding  Mass Development in Real Estates and Agro processng in Uganda";</script><script type="text/javascript" src="http://static.hupso.com/share/js/counters.js"></script><!-- Hupso Share Buttons --></div><htm>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- new1 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-7511299510994171"
     data-ad-slot="7156082642"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</html><br /><br /><span style="font-size:12px;color:#1e73be"><img src="http://xpresstimes.co.ug/wp-content/plugins/j-post-views-counter/images/j-col.png" width="24" height="24" /> This post has been seen 350 times.</span>			</div><!-- .entry-content -->

	<footer class="entry-footer featured-desc">
		<span class="cat-links"><i class="fa fa-folder-o"></i><a href="http://xpresstimes.co.ug/category/business/" rel="category tag">BUSINESS</a></span>	</footer><!-- .entry-footer -->
</article><!-- #post-## -->


	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="http://xpresstimes.co.ug/2020/01/13/katosi-water-works-takes-shape/" rel="prev">Katosi Water Works Takes Shape</a></div><div class="nav-next"><a href="http://xpresstimes.co.ug/2020/01/15/2319-sites-selected-for-cctvs-installation-cross-country/" rel="next">2,319 sites selected for CCTVs  installation cross country .</a></div></div>
	</nav>                <h2 class="widget-title">
			        Related posts                </h2>
		                    <ul class="featured-entries-col featured-entries featured-col-posts featured-related-posts">
		                            <li class="acme-col-3">
                        <figure class="widget-image">
                            <a href="http://xpresstimes.co.ug/2020/01/13/katosi-water-works-takes-shape/">
						        <img width="640" height="427" src="http://xpresstimes.co.ug/wp-content/uploads/2020/01/W3.jpg" class="attachment-large wp-post-image" alt="W3" />                            </a>
                        </figure>
                        <div class="featured-desc">
                            <div class="above-entry-meta">
						                                        <span>
                                    <a href="http://xpresstimes.co.ug/2020/01/15/">
                                        <i class="fa fa-calendar"></i>
	                                                                        </a>
                                </span>
                                <span>
                                    <a href="http://xpresstimes.co.ug/author/admin/" title="">
                                        <i class="fa fa-user"></i>
	                                                                        </a>
                                </span>
                                <span>
                                    <a href="http://xpresstimes.co.ug/2020/01/13/katosi-water-works-takes-shape/#respond"><i class="fa fa-comment"></i>0</a>                                </span>
                            </div>
                            <a href="http://xpresstimes.co.ug/2020/01/13/katosi-water-works-takes-shape/">
                                <h4 class="title">
							        Katosi Water Works Takes Shape                                </h4>
                            </a>
					        <div class="details">National Water and Sewerage Corporation Kampala Water top management team visited site for the new 240...</div>                            <div class="below-entry-meta">
						        <span class="cat-links"><a class="at-cat-item-7" href="http://xpresstimes.co.ug/category/business/"  rel="category tag">BUSINESS</a>&nbsp;</span>                            </div>
                        </div>
                    </li>
			                            <li class="acme-col-3">
                        <figure class="widget-image">
                            <a href="http://xpresstimes.co.ug/2020/01/13/lot-show-case-social-media-party-tycoon-sudhir-ucc-making-1st-ever-fest-slated-possible/">
						        <img width="640" height="640" src="http://xpresstimes.co.ug/wp-content/uploads/2020/01/HE.jpg" class="attachment-large wp-post-image" alt="HE" />                            </a>
                        </figure>
                        <div class="featured-desc">
                            <div class="above-entry-meta">
						                                        <span>
                                    <a href="http://xpresstimes.co.ug/2020/01/15/">
                                        <i class="fa fa-calendar"></i>
	                                                                        </a>
                                </span>
                                <span>
                                    <a href="http://xpresstimes.co.ug/author/admin/" title="">
                                        <i class="fa fa-user"></i>
	                                                                        </a>
                                </span>
                                <span>
                                    <a href="http://xpresstimes.co.ug/2020/01/13/lot-show-case-social-media-party-tycoon-sudhir-ucc-making-1st-ever-fest-slated-possible/#respond"><i class="fa fa-comment"></i>0</a>                                </span>
                            </div>
                            <a href="http://xpresstimes.co.ug/2020/01/13/lot-show-case-social-media-party-tycoon-sudhir-ucc-making-1st-ever-fest-slated-possible/">
                                <h4 class="title">
							        A Lot to show case at the Social Media Party with Tycoon Sudhir and UCC making the 1st ever Fest Slated Possible                                </h4>
                            </a>
					        <div class="details">By Xpress Times Come January 25th this year, Ugandan party animals will gather in one place...</div>                            <div class="below-entry-meta">
						        <span class="cat-links"><a class="at-cat-item-7" href="http://xpresstimes.co.ug/category/business/"  rel="category tag">BUSINESS</a>&nbsp;</span>                            </div>
                        </div>
                    </li>
			                            <li class="acme-col-3">
                        <figure class="widget-image">
                            <a href="http://xpresstimes.co.ug/2020/01/13/a-case-of-nepotism-as-bou-human-resource-boss-gives-son-job-at-bank-even-without-qualifications/">
						        <img width="341" height="255" src="http://xpresstimes.co.ug/wp-content/uploads/2019/06/BOU.jpg" class="attachment-large wp-post-image" alt="BOU" />                            </a>
                        </figure>
                        <div class="featured-desc">
                            <div class="above-entry-meta">
						                                        <span>
                                    <a href="http://xpresstimes.co.ug/2020/01/15/">
                                        <i class="fa fa-calendar"></i>
	                                                                        </a>
                                </span>
                                <span>
                                    <a href="http://xpresstimes.co.ug/author/admin/" title="">
                                        <i class="fa fa-user"></i>
	                                                                        </a>
                                </span>
                                <span>
                                    <a href="http://xpresstimes.co.ug/2020/01/13/a-case-of-nepotism-as-bou-human-resource-boss-gives-son-job-at-bank-even-without-qualifications/#respond"><i class="fa fa-comment"></i>0</a>                                </span>
                            </div>
                            <a href="http://xpresstimes.co.ug/2020/01/13/a-case-of-nepotism-as-bou-human-resource-boss-gives-son-job-at-bank-even-without-qualifications/">
                                <h4 class="title">
							        A Case of Nepotism as BoU human resource boss Gives son Job at Bank even without qualifications                                </h4>
                            </a>
					        <div class="details">&nbsp; Bank of Uganda Director of Human Resource, Dr. Jan Tibamwenda has come under fire for...</div>                            <div class="below-entry-meta">
						        <span class="cat-links"><a class="at-cat-item-7" href="http://xpresstimes.co.ug/category/business/"  rel="category tag">BUSINESS</a>&nbsp;</span>                            </div>
                        </div>
                    </li>
			                    </ul>
            <div class="clearfix"></div>
	        
<div id="comments" class="comments-area">

	
							<div id="respond" class="comment-respond">
				<h3 id="reply-title" class="comment-reply-title"><span></span> Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/01/15/ham-group-and-the-masterminding-mass-development-in-uganda/#respond" style="display:none;">Cancel reply</a></small></h3>
									<form action="http://xpresstimes.co.ug/wp-comments-post.php" method="post" id="commentform" class="comment-form">
						<div style="margin-bottom: 3px;"><b>Or</b></div><div class="fball_ui">
        <div class="fball_form" title="Facebook All"><span id="fball-facebook-login">
        <a href="javascript:void(0);" title="Login with Facebook" onclick="FbAll.facebookLogin();" class="fball_login_facebook"><span>Login with Facebook</span></a></span></div>
        <div id="fball_facebook_auth">
          <input type="hidden" name="client_id" id="client_id" value=""/>
          <input type="hidden" name="redirect_uri" id="redirect_uri" value="http://xpresstimes.co.ug"/>
        </div>
	    <input type="hidden" id="fball_login_form_uri" value=""/>
        </div>																				<p class="comment-form-author"><label for="author"></label><input id="author" name="author" type="text" placeholder="Name" value="" size="30" aria-required="true"/></p>
<p class="comment-form-email"><label for="email"></label> <input id="email" name="email" type="email" value="" placeholder="Email" size="30"aria-required="true"/></p>
<p class="comment-form-url"><label for="url"></label> <input id="url" name="url" placeholder="Website URL" type="url" value="" size="30" /></p>
												<p class="comment-form-comment"><label for="comment"></label> <textarea id="comment" name="comment" placeholder="Comment" cols="45" rows="8" aria-required="true"></textarea></p>						
						<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Add Comment" /> <input type='hidden' name='comment_post_ID' value='9552' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>					</form>
							</div><!-- #respond -->
			
</div><!-- #comments -->

		</main><!-- #main -->
	</div><!-- #primary -->
	<div id="secondary-right" class="widget-area sidebar secondary-sidebar float-right" role="complementary">
		<div id="sidebar-section-top" class="widget-area sidebar clearfix">
			<aside id="search-2" class="widget widget_search"><h3 class="widget-title"><span>Search</span></h3><div class="search-block">
    <form action="http://xpresstimes.co.ug" class="searchform" id="searchform" method="get" role="search">
        <div>
            <label for="menu-search" class="screen-reader-text"></label>
                        <input type="text"  placeholder="Search"  id="menu-search" name="s" value="">
            <button class="fa fa-search" type="submit" id="searchsubmit"></button>
        </div>
    </form>
</div>
</aside><aside id="supermag_posts_col-8" class="widget widget_supermag_posts_col"><div class='at-cat-color-wrap-5'><h3 class="widget-title"><span>LIFE STYLE</span></h3></div>                <ul class=" featured-entries-col featured-entries supermag-except-home featured-col-posts supermag-sidebar">
                                            <li class="acme-col-3 featured-post-main">
                            <figure class="widget-image">
                                <a href="http://xpresstimes.co.ug/2020/01/04/change-uganda-_build-the-nation-campaign-requires-country-men-and-women-thinking-positive-and-ready-to-risk-by-gods-will/">
                                    <img width="300" height="142" src="http://xpresstimes.co.ug/wp-content/uploads/2020/01/ham-6-300x142.jpg" class="attachment-medium wp-post-image" alt="ham 6" />                                </a>
                            </figure>
                            <div class="featured-desc">
                                <div class="above-entry-meta">
                                                                        <span>
                                        <a href="http://xpresstimes.co.ug/2020/01/15/">
                                            <i class="fa fa-calendar"></i>
                                                                                    </a>
                                    </span>
                                    <span>
                                        <a href="http://xpresstimes.co.ug/author/admin/" title="">
                                            <i class="fa fa-user"></i>
                                                                                    </a>
                                    </span>
                                    <span>
                                        <a href="http://xpresstimes.co.ug/2020/01/04/change-uganda-_build-the-nation-campaign-requires-country-men-and-women-thinking-positive-and-ready-to-risk-by-gods-will/#respond"><i class="fa fa-comment"></i>0</a>                                    </span>
                                </div>
                                <a href="http://xpresstimes.co.ug/2020/01/04/change-uganda-_build-the-nation-campaign-requires-country-men-and-women-thinking-positive-and-ready-to-risk-by-gods-will/">
                                    <h4 class="title">
                                        Change Uganda; _Build the Nation Campaign requires Country Men and Women thinking positive and ready to Risk by GOD&#8217;s Will                                    </h4>
                                </a>
                                <div class="details">Hamis Kiggundu (yellow polo shirt ) in china purchasing factory machinery  By Xpress Times In his address on Friday, the President argued the farmers to wake up and start doing better. “We are starting to wake up, God gave us a very beautiful country with so much rain...</div>                                <div class="below-entry-meta">
                                    <span class="cat-links"><a class="at-cat-item-7" href="http://xpresstimes.co.ug/category/business/"  rel="category tag">BUSINESS</a>&nbsp;</span>                                </div>
                            </div>
                        </li>
                    <div class="clearfix"></div><div class="clearfix visible-lg"></div><div class="clearfix visible-sm"></div>                        <li class="acme-col-3">
                            <figure class="widget-image">
                                <a href="http://xpresstimes.co.ug/2019/12/22/improve-your-beauty-and-health-with-a-glass-of-champagne-at-calabash-spa-and-saloon/">
                                    <img width="211" height="300" src="http://xpresstimes.co.ug/wp-content/uploads/2019/12/cal-1-211x300.jpg" class="attachment-medium wp-post-image" alt="cal 1" />                                </a>
                            </figure>
                            <div class="featured-desc">
                                <div class="above-entry-meta">
                                                                        <span>
                                        <a href="http://xpresstimes.co.ug/2020/01/15/">
                                            <i class="fa fa-calendar"></i>
                                                                                    </a>
                                    </span>
                                    <span>
                                        <a href="http://xpresstimes.co.ug/author/admin/" title="">
                                            <i class="fa fa-user"></i>
                                                                                    </a>
                                    </span>
                                    <span>
                                        <a href="http://xpresstimes.co.ug/2019/12/22/improve-your-beauty-and-health-with-a-glass-of-champagne-at-calabash-spa-and-saloon/#respond"><i class="fa fa-comment"></i>0</a>                                    </span>
                                </div>
                                <a href="http://xpresstimes.co.ug/2019/12/22/improve-your-beauty-and-health-with-a-glass-of-champagne-at-calabash-spa-and-saloon/">
                                    <h4 class="title">
                                        Improve your Beauty and Health with a Glass of Champagne at Calabash Spa and Saloon                                    </h4>
                                </a>
                                <div class="details">By Xpress Times This X-mass Season enjoy a glass of champagne when you book a treatment...</div>                                <div class="below-entry-meta">
                                    <span class="cat-links"><a class="at-cat-item-7" href="http://xpresstimes.co.ug/category/business/"  rel="category tag">BUSINESS</a>&nbsp;</span>                                </div>
                            </div>
                        </li>
                                            <li class="acme-col-3">
                            <figure class="widget-image">
                                <a href="http://xpresstimes.co.ug/2019/12/22/merry-x-mass-tycoon-sudhir-ruparelia-dispenses-heart-felt-x-mass-wishes-to-friends-on-face-book/">
                                    <img width="300" height="202" src="http://xpresstimes.co.ug/wp-content/uploads/2019/12/Sudhir-and-wife-Jyostna-always-spend-quality-time-together-300x202.jpg" class="attachment-medium wp-post-image" alt="Sudhir-and-wife-Jyostna-always-spend-quality-time-together" />                                </a>
                            </figure>
                            <div class="featured-desc">
                                <div class="above-entry-meta">
                                                                        <span>
                                        <a href="http://xpresstimes.co.ug/2020/01/15/">
                                            <i class="fa fa-calendar"></i>
                                                                                    </a>
                                    </span>
                                    <span>
                                        <a href="http://xpresstimes.co.ug/author/admin/" title="">
                                            <i class="fa fa-user"></i>
                                                                                    </a>
                                    </span>
                                    <span>
                                        <a href="http://xpresstimes.co.ug/2019/12/22/merry-x-mass-tycoon-sudhir-ruparelia-dispenses-heart-felt-x-mass-wishes-to-friends-on-face-book/#respond"><i class="fa fa-comment"></i>0</a>                                    </span>
                                </div>
                                <a href="http://xpresstimes.co.ug/2019/12/22/merry-x-mass-tycoon-sudhir-ruparelia-dispenses-heart-felt-x-mass-wishes-to-friends-on-face-book/">
                                    <h4 class="title">
                                        MERRY X-MASS; Tycoon Sudhir Ruparelia dispenses Heart Felt X-Mass wishes to Friends on Face Book                                    </h4>
                                </a>
                                <div class="details">By Xpress Times Uganda Typically enterprising, Tycoon Sudhir Ruparelia does it all. He discerns his business...</div>                                <div class="below-entry-meta">
                                    <span class="cat-links"><a class="at-cat-item-7" href="http://xpresstimes.co.ug/category/business/"  rel="category tag">BUSINESS</a>&nbsp;</span>                                </div>
                            </div>
                        </li>
                    <div class="clearfix visible-sm"></div>                        <li class="acme-col-3">
                            <figure class="widget-image">
                                <a href="http://xpresstimes.co.ug/2019/12/11/war-of-rights-new-vision-in-trouble-after-unlawfully-publishing-daily-monitor-photo-journalists-photo-in-bukedde/">
                                    <img width="275" height="183" src="http://xpresstimes.co.ug/wp-content/uploads/2019/12/ME3.jpg" class="attachment-medium wp-post-image" alt="ME3" />                                </a>
                            </figure>
                            <div class="featured-desc">
                                <div class="above-entry-meta">
                                                                        <span>
                                        <a href="http://xpresstimes.co.ug/2020/01/15/">
                                            <i class="fa fa-calendar"></i>
                                                                                    </a>
                                    </span>
                                    <span>
                                        <a href="http://xpresstimes.co.ug/author/admin/" title="">
                                            <i class="fa fa-user"></i>
                                                                                    </a>
                                    </span>
                                    <span>
                                        <a href="http://xpresstimes.co.ug/2019/12/11/war-of-rights-new-vision-in-trouble-after-unlawfully-publishing-daily-monitor-photo-journalists-photo-in-bukedde/#respond"><i class="fa fa-comment"></i>0</a>                                    </span>
                                </div>
                                <a href="http://xpresstimes.co.ug/2019/12/11/war-of-rights-new-vision-in-trouble-after-unlawfully-publishing-daily-monitor-photo-journalists-photo-in-bukedde/">
                                    <h4 class="title">
                                        WAR OF RIGHTS, New Vision in Trouble after unlawfully publishing Daily Monitor Photo Journalist’s Photo in Bukedde                                    </h4>
                                </a>
                                <div class="details">Conceivably New Vision thought they could jump unnoticed when they published a photo, not theirs in...</div>                                <div class="below-entry-meta">
                                    <span class="cat-links"><a class="at-cat-item-7" href="http://xpresstimes.co.ug/category/business/"  rel="category tag">BUSINESS</a>&nbsp;</span>                                </div>
                            </div>
                        </li>
                    <div class="clearfix visible-lg"></div>                </ul>
                </aside><div class='clearfix'></div><aside id="text-38" class="widget widget_text">			<div class="textwidget"><div align="center"><a href="http://www.madhvanifoundation.com/"><img src="http://xpresstimes.co.ug/wp-content/uploads/2018/05/madvani.gif"></a></div></div>
		</aside><aside id="text-34" class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- three -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7511299510994171"
     data-ad-slot="4040642394"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside><aside id="text-44" class="widget widget_text">			<div class="textwidget"><div align="center"><a href="https://www.umi.ac.ug//"><img src="http://xpresstimes.co.ug/wp-content/uploads/2018/05/umi.gif"></a></div></div>
		</aside><aside id="text-26" class="widget widget_text">			<div class="textwidget"><div align="center"><html>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- new7 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:160px;height:600px"
     data-ad-client="ca-pub-7511299510994171"
     data-ad-slot="9251277845"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</html>
</div></div>
		</aside><aside id="text-37" class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- four -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7511299510994171"
     data-ad-slot="7733966089"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside><aside id="text-35" class="widget widget_text">			<div class="textwidget"><a href="http://citygym.co.ug/"><img src="http://xpresstimes.co.ug/wp-content/uploads/2017/10/city-gymn.gif"></a></div>
		</aside><aside id="text-43" class="widget widget_text">			<div class="textwidget"><a href="http://www.isbatuniversity.com/"><img src="http://xpresstimes.co.ug/wp-content/uploads/2018/02/isbat.jpg"></a></div>
		</aside>		<aside id="recent-posts-9" class="widget widget_recent_entries">		<h3 class="widget-title"><span>Recent Posts</span></h3>		<ul>
					<li>
				<a href="http://xpresstimes.co.ug/2020/01/15/2319-sites-selected-for-cctvs-installation-cross-country/">2,319 sites selected for CCTVs  installation cross country .</a>
							<span class="post-date"></span>
						</li>
					<li>
				<a href="http://xpresstimes.co.ug/2020/01/15/ham-group-and-the-masterminding-mass-development-in-uganda/">Ham Group Masterminding  Mass Development in Real Estates and Agro processng in Uganda</a>
							<span class="post-date"></span>
						</li>
					<li>
				<a href="http://xpresstimes.co.ug/2020/01/13/katosi-water-works-takes-shape/">Katosi Water Works Takes Shape</a>
							<span class="post-date"></span>
						</li>
					<li>
				<a href="http://xpresstimes.co.ug/2020/01/13/lot-show-case-social-media-party-tycoon-sudhir-ucc-making-1st-ever-fest-slated-possible/">A Lot to show case at the Social Media Party with Tycoon Sudhir and UCC making the 1st ever Fest Slated Possible</a>
							<span class="post-date"></span>
						</li>
					<li>
				<a href="http://xpresstimes.co.ug/2020/01/13/a-case-of-nepotism-as-bou-human-resource-boss-gives-son-job-at-bank-even-without-qualifications/">A Case of Nepotism as BoU human resource boss Gives son Job at Bank even without qualifications</a>
							<span class="post-date"></span>
						</li>
					<li>
				<a href="http://xpresstimes.co.ug/2020/01/13/five-and-more-reasons-to-study-at-victoria-university-uganda/">Five and more reasons to study at Victoria University Uganda</a>
							<span class="post-date"></span>
						</li>
					<li>
				<a href="http://xpresstimes.co.ug/2020/01/13/bou-deputy-governor-dr-kasekende-contract-expires-without-hopes-of-renewal/">BoU deputy Governor Dr. Kasekende Contract Expires without hopes of renewal</a>
							<span class="post-date"></span>
						</li>
					<li>
				<a href="http://xpresstimes.co.ug/2020/01/07/unsos-donates-to-level-two-force-hospital-in-mogadishu/">UNSOS DONATES TO LEVEL TWO FORCE HOSPITAL IN MOGADISHU</a>
							<span class="post-date"></span>
						</li>
					<li>
				<a href="http://xpresstimes.co.ug/2020/01/04/newly-apointed-updf-amisom-commander-brig-richard-otto-visits-front-line-troops/">NEWLY APOINTED UPDF AMISOM COMMANDER BRIG RICHARD OTTO VISITS FRONT LINE TROOPS.</a>
							<span class="post-date"></span>
						</li>
					<li>
				<a href="http://xpresstimes.co.ug/2020/01/04/change-uganda-_build-the-nation-campaign-requires-country-men-and-women-thinking-positive-and-ready-to-risk-by-gods-will/">Change Uganda; _Build the Nation Campaign requires Country Men and Women thinking positive and ready to Risk by GOD&#8217;s Will</a>
							<span class="post-date"></span>
						</li>
					<li>
				<a href="http://xpresstimes.co.ug/2019/12/22/shopping-made-easier-with-the-arrival-of-kingdom-kampalas-shopping-union-supermarket/">Shopping made easier with the arrival of Kingdom Kampala’s Shopping Union Supermarket</a>
							<span class="post-date"></span>
						</li>
					<li>
				<a href="http://xpresstimes.co.ug/2019/12/22/improve-your-beauty-and-health-with-a-glass-of-champagne-at-calabash-spa-and-saloon/">Improve your Beauty and Health with a Glass of Champagne at Calabash Spa and Saloon</a>
							<span class="post-date"></span>
						</li>
					<li>
				<a href="http://xpresstimes.co.ug/2019/12/22/cabanas-christmas-fest-serves-lavish-christmas-lunch-plus-great-entertainment-on-the-day/">Cabana&#8217;s ChristMas FEST Serves Lavish Christmas Lunch plus great entertainment on the Day</a>
							<span class="post-date"></span>
						</li>
					<li>
				<a href="http://xpresstimes.co.ug/2019/12/22/its-kids-to-party-at-the-dolphins-suites-kids-christmas-pool-party/">It’s Kids to Party at the Dolphins Suites Kids Christmas Pool Party</a>
							<span class="post-date"></span>
						</li>
					<li>
				<a href="http://xpresstimes.co.ug/2019/12/22/makerere-launches-institute-and-names-it-after-kenya-vp-william-ruto/">Makerere Launches Institute and Names It after Kenya VP William Ruto</a>
							<span class="post-date"></span>
						</li>
					<li>
				<a href="http://xpresstimes.co.ug/2019/12/22/wake-up-call-museveni-tells-farmers-that-the-country-is-not-producing-at-her-potential/">WAKE UP CALL; Museveni Tells Farmers that the Country is not producing at her potential</a>
							<span class="post-date"></span>
						</li>
					<li>
				<a href="http://xpresstimes.co.ug/2019/12/22/merry-x-mass-tycoon-sudhir-ruparelia-dispenses-heart-felt-x-mass-wishes-to-friends-on-face-book/">MERRY X-MASS; Tycoon Sudhir Ruparelia dispenses Heart Felt X-Mass wishes to Friends on Face Book</a>
							<span class="post-date"></span>
						</li>
					<li>
				<a href="http://xpresstimes.co.ug/2019/12/20/a-law-student-of-king-ceasor-university-kcu-mr-mutayomba-geoffrey-declared-the-best-in-criminal-proceedings-at-law-development-centre/">A Law student of King Ceasor University (KCU) Mr. Mutayomba Geoffrey declared the best in criminal proceedings at Law Development Centre</a>
							<span class="post-date"></span>
						</li>
					<li>
				<a href="http://xpresstimes.co.ug/2019/12/20/victoria-university-awards-partial-scholarship-to-sharon-mababazi-the-brick-maker/">Victoria University awards partial scholarship to Sharon Mbabazi the brick maker</a>
							<span class="post-date"></span>
						</li>
					<li>
				<a href="http://xpresstimes.co.ug/2019/12/20/no-need-ott-uganda-app-will-help-chat-friends-transfer/">No Need For OTT: This Uganda App Will Help You Chat With Friends And Transfer</a>
							<span class="post-date"></span>
						</li>
				</ul>
		</aside>		</div>
	</div>
        </div><!-- #content -->
        </div><!-- content-wrapper-->
    <aside id="text-41" class="widget widget_text">			<div class="textwidget"><a href="https://balyastinthardware.wordpress.com/"><div align="center"><img src="http://xpresstimes.co.ug/wp-content/uploads/2018/02/bb.jpg"></div></a></div>
		</aside>        <div class="clearfix"></div>
        <footer id="colophon" class="site-footer" role="contentinfo">
            <div class="footer-wrapper">
                <div class="top-bottom wrapper">
                    <div id="footer-top">
                        <div class="footer-columns">
                                                           <div class="footer-sidebar acme-col-3">
                                    <aside id="text-7" class="widget widget_text"><h3 class="widget-title"><span>Folow us on Twitter</span></h3>			<div class="textwidget">            <a class="twitter-timeline"  href="https://twitter.com/XpressTimes_Ug" data-widget-id="674128425574100992">Tweets by @XpressTimes_Ug</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
          </div>
		</aside>                                </div>
                                                            <div class="footer-sidebar acme-col-3">
                                    <aside id="weblizar_facebook_likebox-3" class="widget widget_weblizar_facebook_likebox"><h3 class="widget-title"><span>Facebook</span></h3>		<style>
		@media (max-width:767px) {
			.fb_iframe_widget {
				width: 100%;
			}
			.fb_iframe_widget span {
				width: 100% !important;
			}
			.fb_iframe_widget iframe {
				width: 100% !important;
			}
			._8r {
				margin-right: 5px;
				margin-top: -4px !important;
			}
		}
		</style>
        <div style="display:block;width:100%;float:left;overflow:hidden;margin-bottom:20px">
			<div id="fb-root"></div>
			<script>(function(d, s, id) {
			  var js, fjs = d.getElementsByTagName(s)[0];
			  if (d.getElementById(id)) return;
			  js = d.createElement(s); js.id = id;
			  js.src = "//connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.4";
			  fjs.parentNode.insertBefore(js, fjs);
			}(document, 'script', 'facebook-jssdk'));</script>
			<div class="fb-like-box" style="background-color: auto;" data-small-header="true" data-height="600" data-href="https://www.facebook.com/Xpress-Times-544317319058555/?ref=bookmarks#" data-show-border="true" data-show-faces="true" data-stream="true" data-width="300" data-force-wall="false"></div>
			<div style="display:none;">Facebook By Weblizar Powered By Weblizar</div>
		</div>
        </aside>                                </div>
                                                            <div class="footer-sidebar acme-col-3">
                                    		<aside id="most-viewed-posts-3" class="widget widget_most_viewed widget_recent_entries">		<h3 class="widget-title"><span>Most Viewed Posts</span></h3>		<ul>
					<li>
				<a href="http://xpresstimes.co.ug/2016/05/30/auto-draft-15/">Osita Iheme speaks about his marriage</a>
											<span class="post-views">Views: 74017</span>
									</li>
					<li>
				<a href="http://xpresstimes.co.ug/2016/05/29/gen-sejusa-is-no-longer-a-updf-officer-high-court-rules/">Gen Sejusa is no longer a UPDF officer, High court rules</a>
											<span class="post-views">Views: 60980</span>
									</li>
					<li>
				<a href="http://xpresstimes.co.ug/2016/01/06/dennis-okot-dreams-big-for-kcca-fc/">Dennis Okot dreams big for KCCA FC.</a>
											<span class="post-views">Views: 54402</span>
									</li>
					<li>
				<a href="http://xpresstimes.co.ug/2016/02/01/top-secondary-schools-in-uganda/">Top Secondary Schools in Uganda</a>
											<span class="post-views">Views: 22357</span>
									</li>
					<li>
				<a href="http://xpresstimes.co.ug/2017/12/01/david-de-gea-gets-madrid-ultimatum/">David De Gea &#8220;gets Madrid ultimatum&#8221;</a>
											<span class="post-views">Views: 20583</span>
									</li>
					<li>
				<a href="http://xpresstimes.co.ug/2019/03/24/ivan-semwanga-died-after-made-love-to-my-wife-sharon-o-ronnie-mulindwa/">Ivan Semwanga died after made love to my wife Sharon O- Ronnie Mulindwa</a>
											<span class="post-views">Views: 11173</span>
									</li>
					<li>
				<a href="http://xpresstimes.co.ug/2019/05/24/police-arrests-woman-who-has-been-robbing-high-profile-personalities-in-luxurious-bars-hotels/">Police arrests woman who has been robbing high profile personalities in luxurious bars, hotels</a>
											<span class="post-views">Views: 9530</span>
									</li>
					<li>
				<a href="http://xpresstimes.co.ug/2017/11/08/things-you-will-regret-when-youre-50-years-old/">THINGS YOU WILL REGRET WHEN YOU&#8217;RE 50 YEARS OLD</a>
											<span class="post-views">Views: 8228</span>
									</li>
					<li>
				<a href="http://xpresstimes.co.ug/2016/03/15/top-8-most-expensive-muscle-cars/">Top 8 Most Expensive Muscle Cars</a>
											<span class="post-views">Views: 6387</span>
									</li>
					<li>
				<a href="http://xpresstimes.co.ug/2016/08/17/contraversial-sex-tape-trending-online/">Contraversial sex tape trending online</a>
											<span class="post-views">Views: 6322</span>
									</li>
					<li>
				<a href="http://xpresstimes.co.ug/2016/04/26/father-musaala-nolonger-a-catholic/">Father Musaala nolonger a Catholic</a>
											<span class="post-views">Views: 5568</span>
									</li>
					<li>
				<a href="http://xpresstimes.co.ug/2016/07/09/senga-justine-nantume-quakes-distributing-pornographic-content/">Senga Justine Nantume quakes over distributing pornographic content</a>
											<span class="post-views">Views: 5238</span>
									</li>
				</ul>
		</aside>                                </div>
                                                    </div>
                    </div><!-- #foter-top -->
                    <div class="clearfix"></div>
                 </div><!-- top-bottom-->
                <div class="wrapper footer-copyright border text-center">
                    <p>
                                                    Copyright &copy; All rights reserved                                            </p>
                    <div class="site-info">
                    <a href="https://wordpress.org/">Proudly powered by WordPress</a>
                    <span class="sep"> | </span>
                    Theme: SuperMag by <a href="https://www.acmethemes.com/" rel="designer">Acme Themes</a>.                    </div><!-- .site-info -->
                </div>
            </div><!-- footer-wrapper-->
        </footer><!-- #colophon -->
            </div><!-- #page -->
    		<style>
			.widget_sm_buttons_widget .widget-content {margin: 20px 0;}
			.widget_sm_buttons_widget a {background: ;border-radius: 50px;padding: 10px;}
			.widget_sm_buttons_widget a.facebook {padding: 10px 15px;}
			.widget_sm_buttons_widget a:hover {background: ;-webkit-transition: all 1s;transition: all 1s;}
			.widget_sm_buttons_widget a:hover i {color: ;-webkit-transition: all 1s;transition: all 1s;}
			.widget_sm_buttons_widget i {color: ;font-size: 20px;line-height: 50px;vertical-align: middle;}
		</style>
		<script type='text/javascript' src='http://xpresstimes.co.ug/wp-includes/js/swfobject.js?ver=0071cdabcf9620ab186a7087346cafc9-20120417'></script>
<script type='text/javascript' src='http://xpresstimes.co.ug/wp-content/plugins/banner-manager/load.min.js?ver=0071cdabcf9620ab186a7087346cafc9'></script>
<script type='text/javascript' src='http://xpresstimes.co.ug/wp-content/plugins/bb-plugin/js/jquery.easing.1.3.js?ver=0071cdabcf9620ab186a7087346cafc9'></script>
<script type='text/javascript' src='http://xpresstimes.co.ug/wp-content/plugins/bb-plugin/js/jquery.fitvids.js?ver=0071cdabcf9620ab186a7087346cafc9'></script>
<script type='text/javascript' src='http://xpresstimes.co.ug/wp-content/plugins/bb-plugin/js/jquery.bxslider.min.js?ver=0071cdabcf9620ab186a7087346cafc9'></script>
<script type='text/javascript' src='http://xpresstimes.co.ug/wp-content/themes/supermag/assets/library/theia-sticky-sidebar/theia-sticky-sidebar.js?ver=0071cdabcf9620ab186a7087346cafc9'></script>
<script type='text/javascript' src='http://xpresstimes.co.ug/wp-content/themes/supermag/assets/js/supermag-custom.js?ver=0071cdabcf9620ab186a7087346cafc9'></script>
<script type='text/javascript' src='http://xpresstimes.co.ug/wp-includes/js/comment-reply.min.js?ver=0071cdabcf9620ab186a7087346cafc9'></script>
</body>
</html>